Infiniti G20 Nissan Primera Forum banner

What could it be?

  • Key

    Votes: 0 0.0%
  • Fuel pump

    Votes: 0 0.0%
  • Something else

    Votes: 0 0.0%

  • Total voters
    2
1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello,
I hope everyone is healthy and doing ok .
Thanks to anyone who still follows the forum it's fun to keep these little things alive. Apologies for posting on another thread.
I recently received this issue on the scanner p1610, p1612, p1614 . I was able to to go through the cycle process with the key and it worked for me I cleared the codes. The car drove great worked for 2 target runs I made. Wont start now. Its cranking, even starts for like half a second on a try I made yesterday. I'm lost. I tried the spare key then cycling through again disconnected the battery for a half hour. Dont know if I need a new key or a new igniton immobilizer or worst something I cant fix. Any thoughts ??
#NATS
#Immobilizer
 

·
Registered
Joined
·
106 Posts
wierd no one has replied....anyway so it sounds like the key is working highly unlikely that its the alarm do you hear the fuel pump running? cuase it sounds like those are the usual effects of a bad fuel pump....it has a slow death it'll make you think that its ok but then it dumps on you. and hell maybe check the fuse first if you haven't yet but to me it straight up sounds like the fuel pump cuase theres no code for that. good luck and hope theres more activity on here from more menbers
 
1 - 10 of 10 Posts
Top