Infiniti G20 Nissan Primera Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter #1

·
Registered
Joined
·
172 Posts
Discussion Starter #4
Thanks for putting the pics up SgtDGun. :thumbsup:
 

·
THEY TOOK OUR JOBS!
Joined
·
13,766 Posts
ooh ooh. i like the over sized FMIC. too bad it doesn't quite fill in the "grill space". that'd be so f*cking sweet. maybe njprimera can make you a custom grill.

and is that [email protected]'s BABK?
 

·
p10 guru
Joined
·
2,908 Posts
damn thats a hell of a front mount!! nice choice on the wheels with your car. they match well
 

·
Registered
Joined
·
1,469 Posts
I am curious, do you experiance much lag with the big front mount? I have a friend that swears they lag bad, but i dont know if i should believe him. (i understand that the more plumbing volume there is the more lag there is, but i just want to know if it is very noticeable) It looks great, i cant wait to see more pictures!
 

·
Registered
Joined
·
172 Posts
Discussion Starter #11
P11Gdub said:
ooh ooh. i like the over sized FMIC. too bad it doesn't quite fill in the "grill space". that'd be so f*cking sweet. maybe njprimera can make you a custom grill.

and is that [email protected]'s BABK?
Im gonna have the "fridge" relocated after I get a new bumper, so Ill be able to stick a grill on there, but njprimera does do some nice work. No thats actually the fastbrakes kit.
 

·
Registered
Joined
·
172 Posts
Discussion Starter #12
XnotedgeanymoreX said:
I am curious, do you experiance much lag with the big front mount? I have a friend that swears they lag bad, but i dont know if i should believe him. (i understand that the more plumbing volume there is the more lag there is, but i just want to know if it is very noticeable) It looks great, i cant wait to see more pictures!
Aaaah, the motor is fully built, well apart from the head, and I got a hella turbo on there. So the lag might jsut be from the size of the turbo...but I dont notice it much, cause the motor makes up for it down bottom. Either way Im boosting at about 3500 or so rpm, considering that its a t62-1...Im happy with that :smile:
 

·
Registered
Joined
·
2,138 Posts
Long IC tubing and large ICs dont cause lag. just turbo spool. they mounted twin Turbos at the back of a new mustang and ran the Intake tubes all the way back to the motor and you cant tell any difference the tubes get pressurized instantly as long as the turbos are spooling.
 

·
Registered
Joined
·
172 Posts
Discussion Starter #16
Thanks guys...no dyno #s yet...Ill post em when I have em
 

·
Registered
Joined
·
7,574 Posts
I saw you the other day, I saw the intercooler and was very happy :) Im in Pembroke Pines too. Like I said in the other thread, look for me in a blue NX2000.
 

·
Registered
Joined
·
172 Posts
Discussion Starter #20
Ok Domiken...will do
 
1 - 20 of 20 Posts
Top