Infiniti G20 Nissan Primera Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter · #1 ·
How our g20 members doing?

Had a couple questions as far as maintanace goes on my 02 5sport.

Ive been resolving issues as the car was a "mechanic special" and needed some tlc in areas.

Now ive been driving the car for about 6 months , having repaired most of the original faults restoring it to the beaut she is.

Have a few last things to diagnose and was hoping some other g20 heads could brainstorm with me..

1st off i get a bucking problem from times, looked at spark plugs they were black/ fouled out..changed them and car was running well, knock sensor code when problem returned.

2nd- sometimes @ idle the car temp guage will get to hot and i noticed my radiator fans no longer turn on. changed thermostat and radiator also coolant temp sensor cel is on

3rd- i have a feeling maf/starter/alternator/fuel pump may be the culprits but also did the idle relearn procedure to eliminate the bad idle and it has maintained a health 850rpm

i know this is alot, but if anyone has input from similar experiences pls comment.

Thanks, happy holidays
 

·
The figure it out guy...
Joined
·
1,348 Posts
Are you using OEM parts? What plugs you running now? Bucking so I'm taking a guess it's a 5port? Change coolant temp switch .. run 91 octane and test MaF and replace if bad with OEM. Best I got with the little knowlage of your car.
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #3 ·
turned out the knock sensor code which was thrown with coolant temp sensor was only due to an old and corroded coolant temp sensor..

car has stopped bucking, and threw in new plugs for the extra reassurance..


now onto changing the MT oil as i doubt its been serviced in 60k+ miles..

do we choose 75/90 for the LSD or 80/90?
 

·
Suzie Kl0ne
Joined
·
2,155 Posts
turned out the knock sensor code which was thrown with coolant temp sensor was only due to an old and corroded coolant temp sensor..

car has stopped bucking, and threw in new plugs for the extra reassurance..


now onto changing the MT oil as i doubt its been serviced in 60k+ miles..

do we choose 75/90 for the LSD or 80/90?
the only oil you are gonna want to use for your MT transmisson is Redline MT-90 75W90 GL-4 Gear Oil. this isnt something you cant buy at auto zone or o'reilys.

when i need some i usually go to the local 4x4 shop because they usually have them in stock. i know you can buy it online from ebay or where ever too (if you cant find it locally).

trust me on this one if you want to keep your transmission running strong this is the only oil you want to use. it might seem like a hassle to get some but its the only way to do it.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top