Infiniti G20 Nissan Primera Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi there guys, I have a problem with the radio...I just bought a G20 93.5....the audio system is great, and the radio tunes to all station, BUT! I cant see in wich station I am, there is no number that comes, the led won't light on of the radio, so I cant see in wich station I am or the hour.....it is not the instrumental panel switch that is low, CAN someone help me please?
 

·
Registered
Joined
·
41 Posts
I see you are in Montreal, but I'll still ask a stupid question: has it been pretty warm or has the car been sitting in direct sunlight?

My radio does the same thing, and I've found it typically does it when it is pretty hot or gets pretty warm in the car while sitting (~80*F or higher). But it comes back when it cools off. I think a solder connection is loosing connectivity when expanding, but that would be a PITA to open it up and look for it unless you are pretty good w/ electronics.

Josh
 

·
Registered
Joined
·
392 Posts
i am another one of those ppl with the same problem. i dont use it often but it happened b4. after about a day later, it came back on. now it just has problems playing CDs. kinda stutters and pauses.
 

·
Registered
Joined
·
1,688 Posts
mine did that from the the first day i nought it. when i was installing a cup holder i tilted it forward to see if something was lose andthe lights came back on for like a week then they went out again. i just installed a 06 model alpine unit so i no longer have it.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
hi Foster, I bought the car 2 weeks ago, and it was in a cold area, and in montreal is cold and I can't see the light...Yeah, I should remove the dashboard and look if something is not attached... I was hoping that it was maybe the fusil.
 

·
Registered
Joined
·
171 Posts
This is a fairly common problem with the radio in the 1993.5 G20 and newer. When I had the problem, I took the radio apart and found a cold solder joint inside. After resoldering the joint, I haven't had a problem since. I even bought a radio off of Ebay, and it had the same problem which I fixed.

I wish I could remember where the problem was at, but it has been a few years, and I am getting old.

Don't be afraid to take the radio apart and examine the solder joints on the main board under a manifiying glass.

Jerry
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
uhmm....take the radio apart...it's pretty risky, I dont want to break it....I mean, everything works, with nice audio quality from radio station, don't want to break anything. How do I remove the radio from the dashboard. What are the steps to take the radio off??
 

·
Registered
Joined
·
259 Posts
You simply take the panel trim off first (4 screws and disconnect 2 connectors in the back when taking the trim out). There should be 4 more crews (2 on each side?) that fasten the radio block on the frame. Of course, there are a bunch of connector at the back of the radio unit. You should be able to figure it out youself. Good luck.
 
1 - 9 of 9 Posts
Top