Infiniti G20 Nissan Primera Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1,398 Posts
Discussion Starter · #1 · (Edited)
Hello,

I am replacing my A/C compressor and when putting on the high pressure line to the compressor I noticed that the alignment hole was missing. I don't know if this is the technical term, but it is the hole that the little pin on the metal part of the hose goes into, usually the pin fits in flush in the hole and allows for the hose to be bolted up but without the hole there the metal part does not sit flush with the compressor and has to be moved over in order for the o ring side to sit flush, but now that misaligns the bolt hole and keeps me from bolting it up. Every other A/C component that I replaced yesterday has this alignment hole, but it is missing from the high pressure side of the compressor. I tried to pull out the pin from the hose with a pair of pliers, but it doesn't seem to be able to be removed, so I am stuck on what to do. I thought that I may have been given the wrong part, but the Rock Auto and Autozone website both have the same part number listed. The pictures also have that alignment hole missing. I am unsure if it is the high pressure line, but it is the line that bolts to the front of the compressor and not the top.

Does anyone have any idea on what I need to do?

Thank you!!
 

·
Registered
Joined
·
1,398 Posts
Discussion Starter · #2 ·
I know that this site is pretty much dead, but I'll post what I found anyways. I have a friend who owns a mechanic shop and he told me to clamp down on the pin with vice grips/locking pliers and pull it out. I did that and it came it pretty easily.
 
1 - 2 of 2 Posts
Top