Infiniti G20 Nissan Primera Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
my rpm gauge will just start jumping even will the accesories on and the engine not even started. sometimes it will even go to the music.. do you think it could be a loose ground..? thanks
 

·
Registered
Joined
·
2,120 Posts
You might want to check your battery. From the sounds of it, your battery is no holding enough juice to keep up with the accessories and/or stereo. Do you have an aftermarket stereo, amps, subs, etc.? If so, you'll need a heavy duty battery as well.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #4
no it isnt the battery i checked it i dont have amp subs ect i have aftermarket stereo though i hope it is just the ground
 

·
Registered
Joined
·
2,120 Posts
Zero*2*Infiniti said:
no it isnt the battery i checked it i dont have amp subs ect i have aftermarket stereo though i hope it is just the ground
Just a added thought. You can check the battery and it can register 11.5-14.5 volts but it might not be keeping a full charge when the accessories, etc. are running. If it's an older batttery, I would consider that.

Or your alternator might not be up to par and is not generating enough juice to keep things in par.

Or, could be ground like you said.

Just from past experiance, mine always seemed to be the battery was not strong enough.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #6
but if it was my battery why would everthing else work fine?
 

·
Registered
Joined
·
2,120 Posts
Zero*2*Infiniti said:
but if it was my battery why would everthing else work fine?
Oh crap! I just read your first post. Sorry about that! The actual gauge is jumping around even when the car is off.

[talking to myself]open your eyes JACKASS. It's right in front of you[done talking to myself]

Ok, I would think that it has something to do with the connector that goes to the tachometer. It might be frayed, cut, etc.

Also, going back to your first thought. Check all of the engine grounds. Make sure they are solid and connected.

Also, since you just installed a stereo, make sure that all of the wires you cut into are the correct ones. If you did not use a plug adapter and hot wired everything, that could be your prob'
 

·
Registered
Joined
·
102 Posts
Discussion Starter #8
nismo i will check the tack coneectors but where do i check for them do i have to get up in behind the dash or do i have to take the dash apart..?
 

·
Registered
Joined
·
2,120 Posts
This might be a job for someone with the FSM for a 1991-1993 G20. I have no idea.
 
1 - 9 of 9 Posts
Top