Infiniti G20 Nissan Primera Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter #1
well the other day as i was driving my service engine soon light came on....so i pulled over and briefly examined my car. oil was good and car sounded completely normal in every aspect except one. when i start it up now it sounds as if it struggles just a wee bit. for example it use to take 1 sec to start up and now it takes about 2... anyone have any diagnostics? i would much rather catch a problem sooner the later..


also my gf bro said his check engine light always comes on randomly in his q35. is this just an infiniti thing?
 

·
on to the next one..
Joined
·
4,115 Posts
could be as simple as not having the gas cap on tight. lol

if it is still on, go to autozone and have them read your ses code.
 

·
Registered
Joined
·
392 Posts
5 bucks on the problem is O2 sensor or EGR valve. just kidding
 

·
♥
Joined
·
3,947 Posts
^^^seriously, its probably the rear O2 sensor. nothing to worry about, but get it replaced when you get a chance. bout $100
 

·
Used to own a P10
Joined
·
5,396 Posts
But first get the code read!
 

·
Registered
Joined
·
312 Posts
Discussion Starter #7
now that i think about it would it possibly be the battery? i mean the engine struggles just a little bit to start up now...would the light come on if the battery power is low? havent got a reading yet due to other things...but would this be a possibility?
 

·
♥
Joined
·
3,947 Posts
most likely the alternator for the hesitation rather than the battery. does your abs or ebrake light ever come on?
 

·
♥
Joined
·
3,947 Posts
lol, thats good. battery, abs, and ebrake together mean the alternator is going out just for future reference
 

·
Registered
Joined
·
2,881 Posts
you should defintely have the codes read, autozone can also run a diagnostic on the battery (it's a load test). there are so many things that could affect your starting...starter, battery, could possibly be a faulty EGR valve, etc.....maybe the starting and SES light are unrelated...who knows...

I would get the codes read/have autozone run the batt. diagnostic before replacing anything...For something fast on the battery you could check the voltage on it. AFAIK it should be about 12 volts when the car is off and more like 14 when it is running...
 

·
Registered
Joined
·
312 Posts
Discussion Starter #13
so after i did the codes my self thanks to the handy codes thread i got this
2 codes
2-15
3-4

knock sensor - the knock sensor circuit is open or shorted

fuel system lean - check the injectors, fuel pressure, fuel pressure regulator, oxygen sensor, and/or the MAF sensor

idk what or where the knock sensor is/would be. and i did install a the stillen high flow awhile back and doesnt that deal with the MAF? **NOTE** when i installed the intake i didnt have the ambient air flow sensor plugged up and the light came on when i started it up back when i installed it a couple months ago however the light went off a few days later randomly....


any suggestions?
 
1 - 14 of 14 Posts
Top