Infiniti G20 Nissan Primera Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1
I was surfing the site's posts today and came up with two questions...

1-Has anybody had the situation where the SES, CEL lights up, BUT the OBDII scanner reads "NO CODES"..., and when you unplug the scanner the light turns itself off the next time you start the car?

2-Can anybody explain why BOTH O2 sensors on a 2000 P11 are BEFORE the catalytic converter?

Just wondering...

Robert
 

·
Registered
Joined
·
7,780 Posts
1) I don't know of any cases where someone has had an SES light on but obd2 shows no codes....unless it's some kind of odd electrical short that will throw that light (very small chance), then no. However, you can have codes stored, w/o having your light on. My SES light went out the other day on my 2000 turbo G20 (code due to the EGR), but after scanning it with my obd2, the code was still there.

2) The front O2 sensor has nothing to do with the cat. The front o2 sensor adjusts air/fuel mixture. The only reason point of the rear O2 sensor is to make sure the FRONT cat is there.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #3
Hello people!!

I'm sorry, I have to refer to this post again...
My Check Engine Light is on, my ODBII scanner is recognizing the light as being ON, but it says "No Codes"...however, the I/M monitors on the scanner show something may be wrong with the cat...but my cat was replaced last August.
I changed to a Magnaflow, feels better than the original one.

Even though the scanner states "No Codes" if I press the "Erase" button, this will turn off the check engine light for about 15 minutes of driving, and it will come back on.

I HAVE NO CLUE AS OF WHERE TO START LOOKING...

Has anybody been through this??

Thanks for your help...
 
1 - 3 of 3 Posts
Top