Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
590 Posts
Discussion Starter #1
I have 2 main concerns and wanted to see what you guys think:

1) I figured that my rotors or pad would have uneven wear (that's why they are shaking). So I took them off today to exam them and they look GOOD! No scores anywhere, totally smooth and pads still have great life. I don't see anything uneven. It is only shaky when braking from 80+ and I believe its only from the right side.

2) So I replaced the front with both new rotors and pad. When I started to drive initially it was fine. Later I noticed a repeated *thud* sound. Much like if your rims were not seated correctly and loose. I checked it all and tightened it all. Everything looks fine. (BTW the thud sound is coming from the right side!) I checked underneath the car, everything looks fine. Nothing is bent. Any idea what I can be?!

It can't be a wheel bearing cause they sound more like clicking (cv boot like) then thudding. When I put the car on jacks the front axle spins nicely and I don't see any weird rotation or rubbing or even the noise for that matter. Only when I am driving. It progresses from 5 - 25 mph then its gone. First time this has ever happened to me. Maybe its part of the break- in process?!
 

·
*BANNED FROM G20.NET*
Joined
·
4,911 Posts
recheck and make sure you tightend your caliper(s)...or everything dealing with your brakes. I had the mistake of forgetting to tighten my rear caliper adn two weeks later the screw popped off. luckily nothing big happend. again its just a thought since you replaced your pads and rotors...
 

·
Registered
Joined
·
590 Posts
Discussion Starter #3
Ugly said:
recheck and make sure you tightend your caliper(s)...or everything dealing with your brakes. I had the mistake of forgetting to tighten my rear caliper adn two weeks later the screw popped off. luckily nothing big happend. again its just a thought since you replaced your pads and rotors...
Yeah.. i just checked them all again! Not that.. :(
 

·
Registered
Joined
·
590 Posts
Discussion Starter #5
LOL.. i can see how that is confusing. After hearing the thudding sound I didnt really want to hop onto the freeway. Fastest I have gone was 45mph. and the sound was gone at that point. I am gonna go test drive it again to test. The thud sound progresses from 5 to 25 then gone. I haven't gotten up to 80 yet. Will do that in a bit when traffic is gone. I did go into the store and it started again. If it doesnt go away i think I might have to pop my OE ones back in.
 

·
Registered
Joined
·
2,881 Posts
TE's02p11G said:
LOL.. i can see how that is confusing. After hearing the thudding sound I didnt really want to hop onto the freeway. Fastest I have gone was 45mph. and the sound was gone at that point. I am gonna go test drive it again to test. The thud sound progresses from 5 to 25 then gone. I haven't gotten up to 80 yet. Will do that in a bit when traffic is gone. I did go into the store and it started again. If it doesnt go away i think I might have to pop my OE ones back in.
Gotcha, I think what you're reccomending might be best...going back to OE. If it were long term problem maybe there are some other things you can check. I know I had a "clunk" and it took me forever to find it. It ended up being a caliper bolt that had loosed and then seized in place so the caliper was just bouncing around. The process of taking it apart and putting it back together might help. Check all bushings and sway bar and feel around so see if anything is loose down there. Could be a lot of things.

The only other thing I can tell you is I have found being in the car and listening for clunks can be deceiving. If you can recreate the sound at 5-10mph, maybe you should have someone(s) stand outside and really see if they can hear where the sound is coming from.

Good luck! Hope this helps!
 

·
Registered
Joined
·
590 Posts
Discussion Starter #7
well.. I said. F$#% this took the car out and went 120. Felt no vibrations and started to brake evenly to 80 then release and cruise. so the rotors can cool down. Did that like 3 times. Home now and no more vibrations or strange noises. I guess it is fixed now, maybe that fast driving and braking helped seat the rotors and brakes! All the other rotors I have replaced all and impact screws in them. I guess its fixed!? :) THanks for everyones comments.
 

·
Registered
Joined
·
1,087 Posts
ohh that g20net helpfulness.
 
1 - 8 of 8 Posts
Top