Infiniti G20 Nissan Primera Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,027 Posts
Discussion Starter · #1 · (Edited)
I need help weird noise

So yeah im almost done with putting in my new engine the old on had a loose bearing so i got another one stock. Man this cars are a pain in the ass to swap engines u need to take of everything and all i need now is to go to the junkyard tomorrow to get some transmission screws i lost and maybe get a used axel or try to get the axel boot for one side. My first time changing and engin on this car I have done honda but never a 2.0 from nissan. I started on Thrusday morning and by tomorrow im sure it will be running

Okay i just put everything back together but if im not holding the clutch in it makes and anoying noise i think it might bew the trow out bearing but can it also be that the tranny dosen't have oil. But i don't think it will be that because if im holding it in it dosen't make noise only when the clutch is let go
 

·
Registered
Joined
·
1,027 Posts
Discussion Starter · #3 ·
Yeah i just inconter another problem everything turns on and all but if i let go off the Clutch pedal it makes this anoying noise and if i hold it in it dosen't. It also does it if its in gear
 

·
Registered
Joined
·
755 Posts
I wouldnt guarantee it. Sounds probably though, but could always be the bearing. ALso, I had a noise when the clutch was engaged, with the JGY i put in in my VE swap. After some time, it wouldnt even shift no more. Some springs in the disc-hub had got loose. Never found out if the disc was making the noise or if it was a faulty bearing though. Noise went away when I put in a Centerforce disk and yet another new bearing...DO what Gdub told you, and get to that meet. Never hurts to double-check ;)
 

·
Registered
Joined
·
1,027 Posts
Discussion Starter · #6 ·
blairellis said:
Add tranny oil. I guarantee the noise will go away.
Okay i bought the oil but i can't seem to find the whole to fill it up i've been looking all over the place. All see is the breather but that takes to long
 

·
Registered
Joined
·
1,027 Posts
Discussion Starter · #7 ·
Dulle said:
I wouldnt guarantee it. Sounds probably though, but could always be the bearing. ALso, I had a noise when the clutch was engaged, with the JGY i put in in my VE swap. After some time, it wouldnt even shift no more. Some springs in the disc-hub had got loose. Never found out if the disc was making the noise or if it was a faulty bearing though. Noise went away when I put in a Centerforce disk and yet another new bearing...DO what Gdub told you, and get to that meet. Never hurts to double-check ;)
But if it dosen't work by putting oil i might just take it the shop because san jose is really far from were im at I wish i would of known about this sooner
 

·
Used to own a P10
Joined
·
5,396 Posts
What does the noise sound like?
 

·
Registered
Joined
·
1,027 Posts
Discussion Starter · #9 ·
Like Uhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhh but its kinda loud

Is the oil filler a screw that looks like a socket for a Ratchet?

Thanks for all the response guy's well i hope it's the oil i haven't been able to put it in
 
1 - 9 of 9 Posts
Top