Infiniti G20 Nissan Primera Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
After recently noticing and replacing the drivers side ball joint on my car, a slight squeak in the suspension started to occur. Every time I go over any type of bump in the road, a squeak occurs that is quite loud and annoying. My thoughts were that some type of bushing in the suspension is going bad. It might have been caused by the bad ball joint that I replaced putting abnormal stresses on the suspension, or I could be completely wrong about that. But I think I have narrowed the location of the squeak to the top bolt that holds the shock and spring assembly in place and attaches the assembly to the suspension. (I could be wrong though!) Anyway, I was wondering if anyone else has ever experienced this type of annoying problem and what the fix would be. I haven't noticed any decrease in suspension performace or a change in ride but am worried something is going to break. Any help would be appreciated!
 

·
Registered
Joined
·
235 Posts
My G is having the same problem on the passenger front side. It is something from the upper section of the suspension for sure...I'm getting it checked next week so I'll let you know once I find out the problem, unless you find out first.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks G Rider, it has been driving me crazy! I have tried to diagnose it myself, and have come to the conclusion that it's either the member that mounts to the sub frame bushings are bad, or the third link bushings are bad. I'm not sure if that diagnosis is correct, but please let me know what you find out is wrong with yours, any help would be appreciated!
 

·
Registered
Joined
·
8 Posts
I pretty much have the same problem. My car's front suspension started to squeak about 3 weeks ago (Atlanta got below 40F degrees) when first used in the day/night after going over speed bumps (have a few inside my apartment complex). The squeak seems to go away after the suspension "warms up".

I haven't noticed any leaks so far.

Anyhow...I change my oil today at my local Infiniti, and they lubed the suspension bushings after I pointed this squeak out to them.

I will post any progress here after a few days of testing this quick dealer solution.

I'm concerned because my 2002 ride only has 34K miles and I take very good care of it inside out.

Any suggestions, ideas and opinions are appreciated.
 
1 - 6 of 6 Posts
Top