Infiniti G20 Nissan Primera Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 · (Edited)
A couple days ago, my car won't crank, I can hear some type of electronic motor running without cranking; however, after a couple of tries, it started up and working fine now.

I took it to a local mechanic and explained what happened; he thinks it is the starter.

The thing is the starter was replaced about 2 years ago, and about a year ago around this time of the year, the car did the exact same thing and worked fine until now, and it did it again but working again now.

Do you guys also think it is the starter?
Does it die suddenly like this? or Can you tell a starter is due soon?
If I need a starter soon, which starter should I get? I've search this forum and people say a starter from Autozone and Napa is bad.

BTW, I have a 2000 G20 Automatic.
 

·
Registered
Joined
·
147 Posts
I got over 80k out of the original starter before I had to replace it. I put in a remanufatured one with a lifetime warranty on it from Autozone. Some folks badmouth Autozone electrical stuff but I have never had any trouble with their products. I would check all my connections to ensure they are clean and tight before I would pull out the starter. I replaced mine a few months ago and even though it was time consuming it was not that difficult to do. It is in a hard to reach place however. Just my two cents.
 

·
Registered
Joined
·
68 Posts
my p11 got 197k and 11 years before replacement so a nissan part went back in. You said your car doesn't crank right? does it click or anything? Get a scanner on there to check for pending codes it could possibly be the immobilizer in the steering column going bad as well. also double check connections
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #6 ·
Mine has 137K on it, and the starter was replaced at 118k.
I had a local mechanic do the job, and I doubt he used a Nissan part.

When it acts up, I can only hear electronic motor running sound, like "Wi~~~~~~~~~~~~~ng." No click. Nothing.
Try a couple of times, and it starts cranking weakly(as if it has a low battery or something) and eventually starts up.
Once it starts up, works fine after that. Still working fine.

I scanned it, and there are no pending codes.
How do I check the connections?

Thanks.
 

·
Im a organ donor.
Joined
·
4,843 Posts
they do go out just like that...only time my p11 ever left me stranded was for starter. not a big a deal in a 5spd car but in a auto...you stuck. lol

starter is pretty center of the motor towards the rear. about the size of a coke can.
 

·
Registered
Joined
·
31 Posts
99% certain your mechanic used a remanufactured one. Prob rebuilt in Mexico with varying quality. I had 2 remans burn out on me just like you described and replaced on warrenty for free, but when this one goes out I have a brand new OEM sitting here. Changing the starter is a pain in the ass. Get a new one.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #9 ·
Most everyone seems to have a problem with the REMAN starter.
Okay. The lowest priced OEM starter I have found is $166 + $75 core from order infinity parts.
How do I get my core price refunded from an online order?

Would you suggest a better place to get the OEM starter?
I searched ebay, but they have a new third party(non-brand) starter for $73 and Brand REMAN starters for $120+.
 

·
Registered
Joined
·
23 Posts
mine just went out at the end of November. I finally got a friend to replace it and he used an Ultima (o'reillys?) brand starter. I think that was a bad mistake. It makes a really bad grinding sound when turning the key more then a second. But it does start. I'm seriously considering removing that for a Hitachi or a Denso. Anybody have any experience with using the Denso brand?

I think the main problem with the starter is not the starter itself. Its the location of where the fabulous engineers decided to put it which causes the starters to go bad so quick. It just makes no sense at all.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #12 ·
Based on my search, most people with REMAN have a problem, and the brand doesn't seem matter.
You should go with new.
If Hitachi and Denso are new and the price is same then I would just go with Hitachi since that's the OEM brand.

It seems that the OEM part from order infiniti parts is also REMAN one.
I am thinking about getting new Hitachi ($179 + tax) from NAPA or new Bosch off ebay ($121 no tax).
Does anyone have experience with a Bosch starter?
 

·
Registered
Joined
·
49 Posts
Based on my search, most people with REMAN have a problem, and the brand doesn't seem matter.
You should go with new.
If Hitachi and Denso are new and the price is same then I would just go with Hitachi since that's the OEM brand.

It seems that the OEM part from order infiniti parts is also REMAN one.
I am thinking about getting new Hitachi ($179 + tax) from NAPA or new Bosch off ebay ($121 no tax).
Does anyone have experience with a Bosch starter?
I got a new Bosch two years ago. It's still fine. Got it from amazon.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top