Infiniti G20 Nissan Primera Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok I have an issue that started recently for no reason. Basically went I put the key in and try to crank it, it will click like its dead but the lights are still bright and all. So I tried it again and same thing, again and it started right up. Soo next day the same thing. Tried it a few times... Acted dead then started right up so i took it to a shop he said might be the starter going out so he looked at it and said no it was turning to good... So took it to autozone and they checked the battery and starter and again was told both are operating normally. So I just been trying to try different things but there is nothing im doing different to make it start or not start and now it does it every time but usually starts within the first few tries. It hasn't kept me longer then a minute of spinning the key back and forth to make it start... Im not sure what it could be and don't want to take it to a shop to have them do inspections. Maybe a loose wire or something. I just got the car a few weeks ago but it is a 2000 infiniti g20 with 155k miles but the shop said the motor was recently swapped because it looks so clean and has writing on it. Any help is greatly appreciated, thanks.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Its an auto... I think its the original key but not sure, and yes it clicks one time when i try to crank it. Lately it hasn't been cranking on the first try but sometimes I have to try a few times to get the motor to turn.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top