Infiniti G20 Nissan Primera Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
360 Posts
Discussion Starter #1
I got a quick question..My friends bought me a stillen air filter a while back and its getting pretty grimy..all i wanna do is just clean it up a little..how would i go about that properly without screwing anything up?
 

·
Registered
Joined
·
8,918 Posts
Are you talking about a Pop charger filter? I have a Stillen pop charger on the end of my CAI and I use a K&N filter kit to maintain mine.
 

·
Registered
Joined
·
360 Posts
Discussion Starter #3
yeah thats what i meant sorry about being a little vague..so its just a K&N filter kit and i should be alright?
 

·
Registered
Joined
·
8,918 Posts
Take the filter off, clean it as the directions state then use the oil. Leave the filter sit over night so the oil gets evenly distributed. Re-install in the morning and your G2G. I put mine on right after oiling and had a little puddle of the oil under the car from it not distributing thru the filter properly. :Smile: D
 

·
Registered
Joined
·
360 Posts
Discussion Starter #7
yeah ill prob do it this weekend then, since if the filter needs to sit overnight id have a problem getting to school..seems pretty straight forward though..and i can get this oil from auto zone correct?
 

·
Registered
Joined
·
8,918 Posts
Autozone, Pep boys, Walmart.
Pretty much anywhere and it will last awhile so it's a good investment.
 

·
Registered
Joined
·
360 Posts
Discussion Starter #9
perfect, i gotta get this done soon cuz its pretty dirty and im not sure but it may be killing my gas mileage??
 

·
*BANNED FROM G20.NET*
Joined
·
4,911 Posts
hmmm...maybe tahts why I might have bad gas milage too. I think I should check mine...hopefully its still there.

I dont want to look down and find my unit missing like Cryss :D
 

·
Registered
Joined
·
360 Posts
Discussion Starter #11
haha yeah for the last few months ive noticed im filling my tank up more and more, and then my friend reminded me that i never bothered to clean my air filter..i wouldnt be surprised if we both had the same problem with mileage Ugly :-\
 

·
*BANNED FROM G20.NET*
Joined
·
4,911 Posts
Ive changed my fuel filter, spark plugs, sp wires, dizzy cap , and dizzy rotor but still have yet to see an improvement. Could be my bolt ons too...that and I tend to have a lead foot. Gotta see if my mods made improvements in my performance right? :D
 

·
Registered
Joined
·
360 Posts
Discussion Starter #13
haha yeah i tend to have a lead foot too..i notice that when my friend drives his explorer he averages around 65 on the Hwy and he burns less gas than me it seems..i gotta re-evaluate my driving habits..anyways im off to autozone to get this cleaning kit to see if it makes a difference
 
1 - 14 of 14 Posts
Top