Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,733 Posts
Discussion Starter #1
I'm on the freeway driving to work under wet conditions, car starts to lose power.
I let off the gas, step on it again, the car struggles and the rpms jump to about 2500
and goes back to 2000. Feels as if the car is being kept back. I leave the foot way
on the gas pedal and coast off the road and pulled in a lot. Shut the car off, opened
the hood, nothing out of the ordinary. Turn the car back on, and she drove a bit better
but still hesitates. I make it to work.

I get off work later tonight, warm the car up and drove home. She then does the same
thing and I pull in another lot, now the check engine light comes on? I ended up staying on the feeder and made it home.

Does anyone know what this could be?
Car has 90k miles and it's an auto.

This also happened about 10k back, but I made it to a gas station, got more gas,
and she was fine since. No check engine light at the time.
 

·
The Emo Kid.
Joined
·
6,673 Posts
hmm does it bog a lot?
if you accelerate does it bog down sometimes?
if so could be to do with your maf. weird that it was sudden like that
talk to p11gdub too. that happened 2 days ago, same kinda thing. hes still trying to figure it out...
 

·
Registered
Joined
·
1,733 Posts
Discussion Starter #4
2000 G-Twenty-T said:
hmm does it bog a lot?
if you accelerate does it bog down sometimes?
if so could be to do with your maf. weird that it was sudden like that
talk to p11gdub too. that happened 2 days ago, same kinda thing. hes still trying to figure it out...

Ya, it seems like when it wants to down shift, the tranny won't let the car move.
I'm taking it to Infiniti tomorrow for the oil change so maybe it'll get resolved there.

It's funny only in wet weather, I thought maybe because my car was lowered or
I had gotten bigger wheels on. But it shouldn't cause those problems.
 

·
Registered
Joined
·
1,733 Posts
Discussion Starter #6
ILikeMyRiceSpicy said:
This happened to me once, the sluggish feeling.

Then i realized the e-brake was on :lick:

I'm pretty sure the ebrake's not on, LOLz

It was driving fine and all of the sudden it loses power and hesitates.
 

·
Registered
Joined
·
1,733 Posts
Discussion Starter #8
Came back from Infiniti, it's a 2nd gear silinoid problem.
Good thing I still have a warrenty with my car.
 
1 - 8 of 8 Posts
Top