Infiniti G20 Nissan Primera Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,112 Posts
Discussion Starter #1
I just got my car back from the install. I put a Kenwood deck Rockford Fosgate 6.5in in back and Pioneer 4.6in up front. Damn It sounds so tight. The fosgates have so much bass the mirrors shake. It's awesome. Only one probally when it's real loud the front speakers sound all distorted. I think im going rewire the factory amp because it is only going to the back speakers. Please can you tell me if that would fix the problem or do I have crappy speakers.
 

·
Registered
Joined
·
3,357 Posts
You may want to try and put 6.5 up front too....
I think you get better sounding bass from bigger rounder speakers. I am doing this to my car tommorow. Here are the brackets that I got from Best Buy:


Pics of origanal OEM vs kenwoods ( I am putting Infini Kappa in )




 

·
Registered
Joined
·
1,886 Posts
iv got front and rear kappas 3ways ones with tweeters sounds real nice and clean. u'll be pleased with sound aslong as you have a quailty amp runing to it.

fatboyz921 said:
Only one probally when it's real loud the front speakers sound all distorted. I think im going rewire the factory amp because it is only going to the back speakers. Please can you tell me if that would fix the problem or do I have crappy speakers.
do you have bass blockers on your front and rear speakers? that will help so less bass goes to those and you hear all vocals from those and let your subs do the bass. it will give you a much cleaner sound. i forgot what rating i have on mine they might be the 600mhz ones
 

·
Registered
Joined
·
1,112 Posts
Discussion Starter #4
thanks for the advice, but does any one else know how to fix this problem.
 

·
Registered
Joined
·
138 Posts
ok, so you have your fronts running off the deck correct? and the rears off the factory amp correct? i'd try to run all your speakers off the factory amp and see if that makes it a little better...if not then try to run it directly off the deck and see if you like that better...you gotta remember that your deck most likely isn't putting out that much juice, so when you turn it up too loud the deck is crapping out on you and it'll get distorted.
 

·
Registered
Joined
·
1,112 Posts
Discussion Starter #6
Nismoboy your correct on the speakers. The fronts are runnin off the deck and the rears off the factory amp. I think I'll rewire the factory amp to the fronts. That should fix the problem. If it doesn't then I don't know what it is.
 

·
Registered
Joined
·
158 Posts
I suggest to get a decent amp and replace your 4x6 speakers with 6 1/2. I have a template that I just finished today. It's made out of 1 inch MDF board. It took me awhile to get a decent fit. Days of modifications and thinking and finaly done it today. Should I sell the templates that I made???
 

·
Registered
Joined
·
158 Posts
Oh well..., poppy already blew my business :) The template that I made is for my Boston Acoustics Pro Series 6.4 components but will fit any 6 1/2 speakers. It's a work of art.
 
1 - 8 of 8 Posts
Top