Infiniti G20 Nissan Primera Forum banner

181 - 200 of 224 Posts

·
Registered
Joined
·
1,506 Posts
Discussion Starter #181
standard 8k/6k from FA500. But I haven't installed them yet, I've been sick and haven't done anything car related.
 

·
Registered
Joined
·
33 Posts
This has been great reading through your thread! I just got some basic hand tools in today bought them cheap on groupon just to get me started. Eventually will buy better more reputable tools but 10 bucks for a 52 piece basic socket set seemed like a good deal and I had groupon bucks so it was as close to free as I could get.

I don't have too much time to invest on my P11 but I am hoping to start by replacing the driver side seatbelt which the tensioner is very sticky and won't wind the belt up and the belt is fraying near the buckle.

Can I use a seat belt from a 93.5+ P10? Or do I have to find a 99+ P11 ( almost no 99+ P11's at the PNP's in the Bay Area.)

Also looking into the possibility of getting a new Throttle body as the current one sticks even after I cleaned it out as best I could without removing it from the intake manifold. I don't want to pay 300+ to infiniti if I can get a good used one for cheaper.

Thanks for the inspiration I look forward to seeing more posts!
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #185
This has been great reading through your thread! I just got some basic hand tools in today bought them cheap on groupon just to get me started. Eventually will buy better more reputable tools but 10 bucks for a 52 piece basic socket set seemed like a good deal and I had groupon bucks so it was as close to free as I could get.

I don't have too much time to invest on my P11 but I am hoping to start by replacing the driver side seatbelt which the tensioner is very sticky and won't wind the belt up and the belt is fraying near the buckle.

Can I use a seat belt from a 93.5+ P10? Or do I have to find a 99+ P11 ( almost no 99+ P11's at the PNP's in the Bay Area.)

Also looking into the possibility of getting a new Throttle body as the current one sticks even after I cleaned it out as best I could without removing it from the intake manifold. I don't want to pay 300+ to infiniti if I can get a good used one for cheaper.

Thanks for the inspiration I look forward to seeing more posts!
Thanks for reading. I have certainly enjoyed working on my P10s.
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #188 (Edited)
March 9 - March 27

So during most of the time period, nothing has really progressed. With a combination of busy at work and battling some weird cold which causes exhaustion. A few nights, I found myself sleeping by 7/8pm at night and still tired although feeling a bit better than the previous night....otherwise the cold wasn't the worst, really just a head cold...no sore throat or anything.

But I did start doing some stuff last Thursday, and finished up on Friday. I was finally fed up with the lighting the JDM headlights were providing (which was an improvement over the USDM lights). At night when raining I swear it seems like I had no headlights. So I picked up a set of Philips X-treme Vision H4 bulbs and purchased 2 waterproof Hella 40W relays and weatherpack pig tails. For wire I used 12awg audio wire.

FINALLY I have light!!! To trigger the relays I used the oem headlight wiring and powered the headlights direct from the battery (fused) and grounded them on the main negative ground on the chassis.

I am pretty sure using the Philips bulbs probably made the largest difference in lighting but the wiring certainly had its part. I was only getting about 10v at the wiring beforehand and now I am getting basically 12v (with the car off). So there was some voltage drop there. The bulbs that I had originally were probably oem ones....they said Koito on them (which made the oem headlight housings) so they were rather old.

I am really pleased with the outcome, so I think I will do the same thing with the fog lights.

This past weekend I was gearing up on swapping in the fortune auto coil overs, but got lazy instead. Part of it was me working on some minor stuff for the white car. Anyways, maybe this next weekend, but we shall see.
 

·
Super Moderator
Joined
·
15,155 Posts
I very much dislike white wheels. TE37's are the worst, does Desmonds are a close second. I know I'm probably the ONLY person in the world to feel this way.
Don't take the above as an insult. As Colin will point out, ugly wheel taste runs in my family.
 

·
Suzie Kl0ne
Joined
·
2,153 Posts
I very much dislike white wheels. TE37's are the worst, does Desmonds are a close second. I know I'm probably the ONLY person in the world to feel this way.
Don't take the above as an insult. As Colin will point out, ugly wheel taste runs in my family.
hey as long as the wheels are not black then we're good
 

·
Registered
Joined
·
859 Posts
can we get more info on the ipod thing
Thanks Colin. Yea, I remember reading something about that. I think he mentioned it in chat once. $73 is not bad considering.


So, I had a good test of the alternator output yesterday night. Rained/hailed a ton so had wipers on full, headlights, defrost, and fan was on at 3. The volt meter thing I have showed 13.94v So I think that its working well enough.

I've also concluded that the injector must have been on its way out for a while, idle is super smooth now. Last few days it has been awesome, no misfires anymore!

<3 my car

I also installed a 'radio' in way of an iPod Nano...only recently found out they have built in radio tuners in them. Needed some radio for the commute. Its only a few ounces vs the stock stuff :)
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #193
I very much dislike white wheels. TE37's are the worst, does Desmonds are a close second. I know I'm probably the ONLY person in the world to feel this way.
Don't take the above as an insult. As Colin will point out, ugly wheel taste runs in my family.
LOL thanks. But honestly, I was/am not a white wheel guy. Although it has grown on me, I would have much preferred bronze like Joe or silver. But in the used wheel market at the time it was available and priced well imo. I also figured I could powder coat them if I wanted, although I would loose all the pretty stickers. Since you mentioned it, I would love to get some TE37s one day though.

hey as long as the wheels are not black then we're good
that's right, I see black wheels all the time at work.

can we get more info on the ipod thing
Well, I bought an iPod Nano and carry it with me. Gen 7/8 all have integrated radios in them, I dunno about previous generation Nanos. Its way lighter than a car audio deck and speakers :) i don't think it registers 4oz with headphones, so I didnt bother weighing it and listing it in my weight list.
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #194
So, my cold bacon to the face button is broken. Need to find another...

Hopefully by the end of august I'll have some cool stuff to talk about.
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #197
I wish I had cool things or actually just AC I wish I had AC.
You have plenty of cool stuff, what are you talking about? Lol aww ac is overrated :) having that said I look forward to driving the qn0 car for awhile
You got your replacement/revised lower front mounts from Fortune, correct?
Yep sure did, although that wasnt the cool stuff I was referring to though, other cool stuff :)
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #198



Its great to be able to wash your car at your own home! Always forget I have white wheels on this thing lol

No updates otherwise, car drives really well. Although I noticed it was struggling trying to get up to temp this morning. Maybe the thermostat needs to be changed.
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #199
So, after selling, moving, closing today was the 1st weekend I had a chance to work on a car. This car got the nod as it's removed parts will lend itself to the 20v car :)

Fortune coilovers have been installed!
I kind of was putting this off as I knew it wouldn't go together as easy as standard oem replacement stuff.

The rear end gave me the most problems, I didnt take a photo but the upright bracket needs massaging in order for the bottom bolt to fit. FA had cut the bracket back a bit, but its not enough and hits the unmachined part of the upright causing the bolt hole not to line up. Nothing major, after figuring out the problem a few minutes with the file fixed it up.

Rear installed.


Shitty front pic


Fortune didnt seem to provide any guidelines/starting points as far as ride setting so I winged it a bit. The front I started out with 2.75" of threads from the bottom spring perch lock ring to the top of the lower shock mount piece. Rear I tried 4 1/8". Seems like I need to go down a bit more on the rear end.

In the group buy the revised lower shock mounts were provided afterwards in the pic you can see the cut back portion for clearance. I liked the green better.


In this pic you can see that the rear doesn't look too lowered at all



Front gap, I had about 4-4.5" of gap, looks like about 2"-2.5" now, car sitting considerably lower up front.


I didn't think I'd get any weight savings on this upgrade, but I did.
AGX w/ oem springs 61lbs 8oz
FA500s - 45lbs 4oz

So that's a nice 16lbs reduction :)


So I dont' have any driving impressions yet since the car was blocked in. That and I want to adjust the rear end more and get an alignment done. I hope to get it adjusted sometime next week.
 
181 - 200 of 224 Posts
Top