Infiniti G20 Nissan Primera Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
ok this is going to sound really stupid but i have to ask. Im doing a motor swap in my b13. I got the motor off one of the forum members off of sr20forums. The guy told me it was a 94 g20 sr20de obdI whatever right... well it comes to find out that the motor is obdII i had to change a bunch of things. i dont even kno what year motor it is and now i cant find the right valve cover gasket(well all the gasket are the same just diffrent groments that come with it)... alot of the motors that i have seen have the studs comming from the head and you use the nuts to tighten the valve cover down... i dont have the studs and the nuts i have the actuall bolts thats screws in the head... i got a valve cover gasket but wrong groments. the gasket was for a 94. So what year valve cover gasket do i have to get for groments to match the bolts
 

·
Registered
Joined
·
76 Posts
Discussion Starter #3
i was thinking about that.. i will get some pics tomorrow since its sitting in the shop all the pics i got dont show what im talking about..
 

·
CH0DEmobile
Joined
·
3,202 Posts
All FWD V/C's are the same, unless you got a RR motor? throw up whatever pics of the motor you've got, I'm sure someone on here can identify it.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #5 (Edited)
yea i kno all the valve cover gasket are the same for fwd and i kno its a regular usdm motor because the gasket i got fit nicely just the groments didnt work with the bolts... p10 told me that the 99 and up G20s have the bolts to bolts down the valve cover and 98 and down have the nuts that you screw in the stud. but i went to advance and they didnt have a picture and i dont wanna be wasting my time ordering stuff i dont need
 

·
I ♥ Zac Efron!
Joined
·
1,877 Posts
not to hijack thread...but when you are removing your valvecover to paint it, is the only thing you need to get while putting it back on valvecover gaskets?
 

·
Registered
Joined
·
76 Posts
Discussion Starter #10 (Edited)
this is the motor..

when i first got it


in the car


out of the car


bling lol



i will get pics of what im talking about soon. i already took them i just need to upload them in my computer. im at work so i cant do it here
 

·
Registered
Joined
·
76 Posts
Discussion Starter #12
thanks for the bump but nobody helped... which im really suprize... anyways i just said the hell with it took a drill to the groment to wided the hole enought that i can put the bolt through.... PRESTO !
 

·
Registered
Joined
·
76 Posts
Discussion Starter #14
yeah i was... somebody told me that the 94 and below they had the studs and the 95 and up had the bolts... the little metal and ruber washers that came with it the hole was way to small so the bolt didnt go through.. i just took a drill to the metal part and made it bigger and t worked
 
1 - 16 of 16 Posts
Top