Infiniti G20 Nissan Primera Forum banner

1 - 9 of 9 Posts

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
Discussion Starter #1
1997 P11 SR20 Auto 58K

A few months ago I had a squeeky water pump ....... Kept dropping oil in to its lil lube hole (20W50 wiv a syringe) & it used to shut up then come back later (a few weeks)

The squeek was mainly when it was cold ........

Anyways I got fedup with all that nonsence once the coolant started disapeering so I changed the water pump, & as I had the system in bits I changed the thermostat & flushed the system.

ANYWAYS the freakin' squeek (Till warm has returned) ...... it shuts up if you rev the engine...... & shuts up completely if you oil it :shock: ...... The belts don't seem too tight to me, not drumstring tight, but you cant flop em around too much ;)

Should I just keep oiling the ferker & SHADDAP ..... Or does somone have wise words to say ?

The replacement parts were Thermo (OEM) Pump was Joe soap enterprises.... but it was a good bitta kit, well made & all, fitted bang on & no sharp edges :zoinks:

What says you gurus? :beard:
 

·
Registered
Joined
·
1,361 Posts
There is no oil hole on a water pump. That is actually a bleed hole which will leak coolant when the bearings and seals are worn.
If it squeaks with the new pump, then I would say it is not the pump itself. I would look at replacing the belt and making sure it is properly tightened. You may also want to make sure that the pump pulley lines up with the other pulleys. Make sure the pump pulley is not bent. Inspect the belt for contamination.
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
Discussion Starter #4
jjacob said:
There is no oil hole on a water pump. That is actually a bleed hole which will leak coolant when the bearings and seals are worn.
Bleed hole pointing upwards ? :scream:
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
Discussion Starter #5
gomd3 said:
could it be mud that's still up in there. jking :)
Took me bloody hours to jetwash all the goop off of the freakin car :*(
 

·
drunken master
Joined
·
10,091 Posts
I say first run the engine andlook at the pullys inline to ivestigate any play if their is no noticable play then remove belts to inspect retriction on all pullys. if non found replace the belts but get the oil off the pullys first. if yo narowed it down previuosly to wich belt is sqeeking than it may save a lil time.
if you are going to rplace the belts then dont forget to check for thing also to be mounted secure.
good luck
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
Discussion Starter #7
My plan is thus:

Do nothing till summer, if somthing falls off during the mean time, get out there in the cold & fix it.

When summer arrives, change belts & frig around ;)
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
Discussion Starter #9
Tis a tad silly innit :(
 
1 - 9 of 9 Posts
Top