Infiniti G20 Nissan Primera Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
the car died for more than a month, before it died, it vibrated a lot, and then died. I figured out what caused the vibration, the #3 injector was bad, I just replaced this injector today, but car still won't start up.
I recorded the sound that I started up my car, who can tell me what happened?
the sound of start up
 

·
CH0DEmobile
Joined
·
3,202 Posts
Yep, your starter is working, but it sounds like you've got a pretty weak battery. It almost sounds like you've got low-to-no compression, but I could be wrong, that was a pretty short clip. Change/charge your battery, and see if it'll start. Make sure you're getting a spark and fuel, maybe you disconnected something while installing the injector?
 

·
Registered
Joined
·
2,107 Posts
Newer electronic FI engines take a lot more power to start up. Your starter sounds OK. Sounds like no spark or fuel- I'd check those items out first.
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
Don't sound like its firing ........ & it could do with spinning over a lil quicker :)
 

·
Registered
Joined
·
80 Posts
Discussion Starter #7
Actually, I checked the spark plug by pulling them out, and connect to engine body, it has spark, and i put a stick into engine, there is also fuel spray on it while i try to start up the car. But i don't know whether the fuel injected is enough?
I unplug the pipe runs to top of the fuel filter, and put another test pipe on it, and turn key to "on", there are fuel pumping out.
 
1 - 7 of 7 Posts
Top