Infiniti G20 Nissan Primera Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
Hi all,

I bought a 2000 G20 last month and the car is one trouble maker.

It has cost me $900 in parts replacement.
I had to replace the following:
front struts, front motor mount, rear motor mount, passenger side motor mount, and now wipers :(

It snowed here last week and me being a dumbass decided to turn on the wipers. As soon as I turned then on I heard a loud snap and now my wipers are dead.

I searched this forum for similar problems and I found many threads, however I am a noob when it comes to this car.

I dont know what the parts look like or anything. But I did try to take the wiper arm off this morning.

Here is what I did so far:
1. popped off the black round cover at the end of the wiper arm
2. unscrewed the bolt
3. i tried to pull the wiper arm out but it didnt work.

so what should i do? how do i bring my wipers back to life?

Also where is the t-stat located in my 2000 g20?
 

·
Premium Member
Joined
·
11,585 Posts
What will have happened is that one of the linkage rods between the motor and the pivots will have popped off. I had this happen on my P10 the other week.

To get the wiper arm off the spindle, you have started off well but you'll need to lift the wiper away from the screen then wiggle it to pull it off...

The t-stat is where the bottom rad hose connects to the engine.
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
is the wiper motor running ?
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #5 ·
markbut3 thanks for the info but I just cant get the wiper arm off!

I have unscrewed the bolt, and then i pulled the wiper arm away from the windshield but when i try to pull it, it doesnt even move. Do I have to yank it out?

Also do I have to unscrew both wiper bolts in order to take them off?

Another thing: My car's hood comes in my way when I try to pull on the driver side wiper. Is it supposed to be that way?

JM: yes i can hear my motor making the sound, its just the wipers wont move. But if I try to move them manually then move easily.
 

·
Premium Member
Joined
·
11,585 Posts
The spindle is splined and tapered so they can be tight.

I can't think what the P11 is like but what I had to do was remove the pass side wiper (pivot in the centre of the car) and then the screws and seal securing the plastic scuttle to get to the linkages. It ended up being the actual metal ball on the wiper motor that had worn on mine so I had to swap the motor with a spare I had.
 

·
Registered
Joined
·
431 Posts
TroubleTwenty said:
markbut3 thanks for the info but I just cant get the wiper arm off!

I have unscrewed the bolt, and then i pulled the wiper arm away from the windshield but when i try to pull it, it doesnt even move. Do I have to yank it out?

Also do I have to unscrew both wiper bolts in order to take them off?

Another thing: My car's hood comes in my way when I try to pull on the driver side wiper. Is it supposed to be that way?

JM: yes i can hear my motor making the sound, its just the wipers wont move. But if I try to move them manually then move easily.
Tip: Pour some hot water on the splined area to loosen the splines. The arms will come off with patience.

On LHD (US) P10's, when you lift the driver's side wiper arm, it will come up just underneath the hood (have the hood raised, of course).
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
markbuts3 said:
The spindle is splined and tapered so they can be tight.

I can't think what the P11 is like but what I had to do was remove the pass side wiper (pivot in the centre of the car) and then the screws and seal securing the plastic scuttle to get to the linkages. It ended up being the actual metal ball on the wiper motor that had worn on mine so I had to swap the motor with a spare I had.
I found it all to be a right pain in the ass to re-assemble ........ As far as getting the wiper arms off goes ....... Pop the top off undo the nut & waggle the arm till it comes off.

Take the plastic cover off the base of the screen (It may be glued to the screen)

each wiper pivot has three bolts holding them in place ......... Undo the wiper motor, take that off ...... Slide all the linkages out thro that hole over on the passenger side ........ Right you got it all to bits :D

Fix or replace the jiggered bits & re assemble....... Slide all of it back in thro that hole on the passenger side re locate the pivots & just put the bolts in a couple O turns ..... Now for the tricky bit ...... Getting the wiper motor to connect back on to the linkage assy.... Once you have managed that one (It ain't easy) Bolt up the motor & generally re assemble :) :beard:

Yes its a arse of a job :(
 

·
Registered
Joined
·
107 Posts
if the motor is running, most likely the linkage... i just had to replace mine... they were like $12 each from a dealer. if the motor isnt working pray its a fuse.
 

·
Registered
Joined
·
23 Posts
I just got my 2000 g20 recently also and mines a trouble maker too. just today the exact same thing happened to me. I hear the wiper motor running, but the wipers don't move. I guess now I'm stuck disassembling my wiper assembly too to get to the problem.
 

·
Registered
Joined
·
1,707 Posts
The link arms could have broken on the wipers...see what Mark mentioned as that has happened to me also - its an expensive repair if done by the dealer but it can be done relatively cheap if you can disassemble and get to the root. The parts will be the only 'ouch'.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #16 ·
Here is what I did:

Unscrew the wiper bolts. Then push on the wiper with one hand towards teh windshield and it should pop out. If the wiper doesnt pop out then use some muscle and give it some time and it will eventually come off.

2) Remove the plastic cover underneath the windshield. The screen type thing.

3) Find out which rod came off. And check and see if it is broken or not

4) pop it back in and turn on the wipers. If it pops right out that means its broken

5) Go to a near by Infiniti dealer (these are dealer parts and u cant buy them at other auto parts)

6) Replace the rod. (Pain in teh arse)

7) Try the wipers again and it should work.

BETTER SOLUTION: Download the 2000 G20 FSM from phatg20 website and search for the wiper replacement instructions.
 

·
Registered
Joined
·
23 Posts
Alright, so I was just under hood for half an hour taking off the wipers and plastic cover and whatnot. I see that the rod connecting from the wiper motor to the passenger side wiper had popped off. I don't think anything is broken. So I pop it back on there, put everything back together, try the wipers, they move up once and I hear a pop. the rod popped right off again after one wipe. now I'm pissed off and I guess I'll give it another try tomorow. definetly a pain in the ass. how do I get that rod to stay connected to the passenger wiper there?

the tip about using hot water to get off the wipers worked great too.
 

·
Pizdeet kak Trotsky
Joined
·
3,069 Posts
1. Replace the rod

2. Wrap some wire around the joint....... Its gonna fall off again tho :(

Get some Aquapel ........ Don't need wipers then :D
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #19 ·
You will have to buy a new rod

Go to the nearest Infiniti dealer/parts guy and get it. It should be less than $20 bucks.

Mine was like $12.


Taking the broken rod off is easy, putting the new one in is a pain in the ass. Its so hard putting ur hand into that little opening.

Also keep on trying, it will snap/slide into place eventually. Dont give up
 

·
Registered
Joined
·
1,892 Posts
Fuk I think this just happened to me today. This should be fun to fix.
 
1 - 20 of 22 Posts
Top